Author Topic: Error while trying to load my own mod  (Read 381 times)

0 Members and 1 Guest are viewing this topic.

April 08, 2018, 07:56:14 PM
Read 381 times

yonyi

  • *
  • Information
  • Newbie
  • Posts: 1
    • View Profile

So I've tried to make my first mod using the "test mod" provided here in the forum and this error keeps appearing. https://i.imgur.com/0HOyhJ9.png

Here's my code, I can't seem to find the error.
Code: [Select]
<SoftwareType>
<Name>Video Editor</Name>
<Category>Video Editing</Category>
<Description>Handles the post-production video editing of digital video.</Description>
<Random>0.25</Random>
<Unlock>1990</Unlock>
<Categories>
<Category Name="Default">
<Description>Video Editor on a computer.</Description>
<Popularity>0.87</Popularity>
<Retention>0.8</Retention>
<TimeScale>1</TimeScale>
<Iterative>0.7</Iterative>
<NameGenerator>Video_Edit</NameGenerator>
</Category>
</Categories>
<OSSpecific>TRUE</OSSpecific>
<OneClient>FALSE</OneClient>
<InHouse>TRUE</InHouse>
<Features>
<Feature Forced="TRUE">
<Name>Timeline</Name>
<Description>A linear layout of your video that displays all the media in your project and exactly how long they appear on screen.</Description>
<DevTime>1</DevTime>
<Innovation>0</Innovation>
<Usability>1</Usability>
<Stability>0</Stability>
<CodeArt>0.5</CodeArt>
</Feature>
<Feature>
<Name>Storyboard</Name>
<Description>Displays each video clip in its own thumbnail, regardless of how long it appears on screen.</Description>
<DevTime>2.5</DevTime>
<Innovation>2</Innovation>
<Usability>3</Usability>
<Stability>1</Stability>
<CodeArt>1</CodeArt>
<SoftwareCategory Category="Default">1992</SoftwareCategory>
</Feature>
<Feature>
<Name>Effects</Name>
<Description>This feature takes just as many artists as programmers and offers no stability.</Description>
<DevTime>5</DevTime>
<Innovation>1</Innovation>
<Usability>1</Usability>
<Stability>0</Stability>
<CodeArt>0.5</CodeArt>
<Dependency Software="Video Editor">Timeline</Dependency>
<SoftwareCategory Category="Default">1993</SoftwareCategory>
</Feature>
</Features>
</SoftwareType>

May 09, 2018, 07:18:08 PM
Reply #1

fw190a8

  • *
  • Information
  • Newbie
  • Posts: 4
    • View Profile
Your "Timeline" feature is missing a Category tag. It needs to have a Category tag such as 2D, 3D, Algorithm, etc that matches one of the skills in the game, otherwise the game will not know which skill is required to develop it.

You will need to do this for all your features, because they will all give this error!